阅读( 333 )次

   评论(0)条

一路向北

《TensorFlow 中级教程》第一章学习笔记

在第一章的自适应编码器代码中有使用matplotlib进行绘图。

但当我在Jupyter Notebook中运行程序是却总是出现下面这个错误

```

D:\anaconda3\envs\tensorflow\lib\site-packages\matplotlib\figure.py:459: UserWarning: matplotlib is currently using a non-GUI backend, so cannot show the figure

  "matplotlib is currently using a non-GUI backend, "

```


后来,通过科学上网,在Google上搜到如下解决方法.

就是在`import matplotlib.pyplot as plt`之前加入下面这两行代码:

```

import matplotlib

matplotlib.use('TkAgg')

```

希望对其他童鞋有帮助。

 收藏 (0)  打赏  点赞 (1)

 ©2017 studyai.com 版权所有

关于我们